华域联盟 易语言 易语言做软件更新的方法

易语言做软件更新的方法

易语言软件更新源码,利用QQ空间名称做更新,简单方便快速。

1、首先打开易语言,新建一个窗口。

2、分别在窗口添加3个编辑框,一个按钮。 编辑框2写入内容。注明:编辑框1带取网页源码内容,编辑框3是取编辑框1相应的内容,编辑框2内容是和编辑框3内容做对比,按钮1是用来判断编辑框2和编辑框3内容做对比。

3、进入空间QQ空间,修改QQ空间名称,修改“→”  “修改这中间数字即可” “←”

4、双击_启动窗口,写入相应的代码。

.版本 2.支持库 internet.支持库 iconv.支持库 RegEx

.子程序 __启动窗口_创建完毕.局部变量 字节集, 字节集

字节集 = HTTP读文件 (“这里填写QQ空间首页地址”)字节集 = 编码转换 (字节集, #编码_UTF_8, #编码_GB18030, )编辑框1.内容 = 到文本 (字节集)编辑框3.内容 = 取文本中间内容 (编辑框1.内容, “→”, “←”)

.子程序 取文本中间内容, 文本型, 公开, 取文本中间.参数 欲搜寻的文本, 文本型, , 要搜索的总文本.参数 左边文本, 文本型.参数 右边文本, 文本型.参数 是否循环搜索, 逻辑型, 可空, 是否循环搜索,可空默认为假.参数 结果数组, 文本型, 参考 可空 数组, 可空,如果循环搜索为真的话,此数组返回搜索的结果,需要传一个文本数组接收,返回结果将变为搜索到的个数.参数 是否不区分大小写, 逻辑型, 可空, 可空默认为假.局部变量 表达式一, 正则表达式.局部变量 搜索结果一, 搜索结果, , "0".局部变量 搜索结果二, 搜索结果.局部变量 i, 整数型.局部变量 返回文本, 文本型

.如果真 (欲搜寻的文本 = “” 或 左边文本 = “” 或 右边文本 = “”)  输出调试文本 (“不解释,你懂得”)  返回 (“”).如果真结束左边文本 = 过滤特殊字符 (左边文本)右边文本 = 过滤特殊字符 (右边文本)表达式一.创建 (左边文本 + #正则表达式一 + 右边文本, 是否不区分大小写).判断开始 (是否循环搜索 = 真)  搜索结果一 = 表达式一.搜索全部 (欲搜寻的文本)  .计次循环首 (取数组成员数 (搜索结果一), i)    加入成员 (结果数组, 搜索结果一 [i].取子匹配文本 (欲搜寻的文本, 1, ))  .计次循环尾 ()  返回 (到文本 (取数组成员数 (搜索结果一))).默认  搜索结果二 = 表达式一.搜索 (欲搜寻的文本, 1, )  返回 (搜索结果二.取子匹配文本 (欲搜寻的文本, 1, )).判断结束

.子程序 过滤特殊字符, 文本型.参数 字符串, 文本型

字符串 = 到小写 (字符串)字符串 = 子文本替换 (字符串, “|”, “\|”, , , 假)字符串 = 子文本替换 (字符串, “(”, “\(”, , , 假)字符串 = 子文本替换 (字符串, “/”, “\/”, , , 假)字符串 = 子文本替换 (字符串, “)”, “\)”, , , 假)字符串 = 子文本替换 (字符串, “[”, “\[”, , , 假)字符串 = 子文本替换 (字符串, “]”, “\]”, , , 假)字符串 = 子文本替换 (字符串, “?”, “\?”, , , 假)字符串 = 子文本替换 (字符串, “.”, “\.”, , , 假)字符串 = 子文本替换 (字符串, “\”, “\\”, , , 假)字符串 = 子文本替换 (字符串, “^”, “\^”, , , 假)字符串 = 子文本替换 (字符串, “$”, “$”, , , 假)字符串 = 子文本替换 (字符串, “*”, “\*”, , , 假)字符串 = 子文本替换 (字符串, “+”, “\+”, , , 假)字符串 = 子文本替换 (字符串, “}”, “\}”, , , 假)字符串 = 子文本替换 (字符串, “{”, “\{”, , , 假)字符串 = 子文本替换 (字符串, “-”, “\-”, , , 假)返回 (字符串)

 

5、双击按钮1,写入相应代码。 

.版本 2

.子程序 _按钮1_被单击

.如果 (编辑框3.内容 = 编辑框2.内容)  信息框 (“最新版本”, 0, “提示”)  返回 ().否则  .如果 (编辑框3.内容 ≠ 编辑框2.内容)    信息框 (“需要更新”, 0, “提示”)    返回 ()  .否则

  .如果结束

 

6、点击运行测下,弹出相应的提示,看是否是最新版。

7、完成。做更新方法多是多样。 完成。做更新方法多是多样。

本文由 华域联盟 原创撰写:华域联盟 » 易语言做软件更新的方法

转载请保留出处和原文链接:https://www.cnhackhy.com/105572.htm

本文来自网络,不代表华域联盟立场,转载请注明出处。

作者: sterben

易语言制作国王的勇士辅助步骤

发表评论

联系我们

联系我们

2551209778

在线咨询: QQ交谈

邮箱: admin@cnhackhy.com

工作时间:周一至周五,9:00-17:30,节假日休息

关注微信
微信扫一扫关注我们

微信扫一扫关注我们